Repository navigation
REMOVE support to python3.10 #25306
New issue
Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.
By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.
Already on GitHub? Sign in to your account
REMOVE support to python3.10 #25306
Changes from 6 commits
11ed859
4a49266
e34d325
41991c6
3d5d5d2
53ee63c
582e5ed
5ea99b7
File filter
Filter by extension
Conversations
Jump to
Diff view
Diff view
There are no files selected for viewing
| Original file line number | Diff line number | Diff line change |
|---|---|---|
|
|
@@ -15,11 +15,11 @@ jobs: | |
| fail-fast: false | ||
| matrix: | ||
| python-version: | ||
| - "3.10" | ||
| - "3.11" | ||
| - "3.12" | ||
| - "3.13" | ||
| - "3.14" | ||
| - "3.15" | ||
|
Contributor
There was a problem hiding this comment. Choose a reason for hiding this commentThe reason will be displayed to describe this comment to others. Learn more. P2: This new Python 3.15 matrix entry runs the Pydantic v1 samples, but Pydantic v1 does not support Python 3.15, so these CI jobs will fail or exercise an unsupported environment. Remove this entry or migrate the samples before testing Python 3.15. Prompt for AI agents |
||
| sample: | ||
| - samples/openapi3/client/petstore/python-pydantic-v1-aiohttp | ||
| - samples/openapi3/client/petstore/python-pydantic-v1 | ||
|
|
||
| Original file line number | Diff line number | Diff line change |
|---|---|---|
|
|
@@ -10,7 +10,7 @@ from setuptools import setup, find_packages # noqa: H301 | |
| # http://pypi.python.org/pypi/setuptools | ||
| NAME = "{{{projectName}}}" | ||
| VERSION = "{{packageVersion}}" | ||
| PYTHON_REQUIRES = ">= 3.10" | ||
| PYTHON_REQUIRES = ">= 3.11" | ||
|
Contributor
There was a problem hiding this comment. Choose a reason for hiding this commentThe reason will be displayed to describe this comment to others. Learn more. P2: Changing this constant does not enforce the new minimum because Prompt for AI agents |
||
| REQUIRES = [ | ||
| {{^async}} | ||
| "urllib3 >= 2.7.0, < 3.0.0", | ||
|
|
||
| Original file line number | Diff line number | Diff line change |
|---|---|---|
|
|
@@ -21,7 +21,7 @@ | |
| # http://pypi.python.org/pypi/setuptools | ||
| NAME = "openapi-client" | ||
| VERSION = "1.0.0" | ||
| PYTHON_REQUIRES = ">= 3.10" | ||
| PYTHON_REQUIRES = ">= 3.11" | ||
|
Contributor
There was a problem hiding this comment. Choose a reason for hiding this commentThe reason will be displayed to describe this comment to others. Learn more. P2: This update does not enforce the Python 3.11 floor because Prompt for AI agents |
||
| REQUIRES = [ | ||
| "urllib3 >= 2.7.0, < 3.0.0", | ||
| "python-dateutil >= 2.8.2", | ||
|
|
||
| Original file line number | Diff line number | Diff line change |
|---|---|---|
|
|
@@ -20,7 +20,7 @@ | |
| # http://pypi.python.org/pypi/setuptools | ||
| NAME = "legacy-model-dict-client" | ||
| VERSION = "1.0.0" | ||
| PYTHON_REQUIRES = ">= 3.10" | ||
| PYTHON_REQUIRES = ">= 3.11" | ||
|
Contributor
There was a problem hiding this comment. Choose a reason for hiding this commentThe reason will be displayed to describe this comment to others. Learn more. P2: This version change does not affect the published package because Prompt for AI agents |
||
| REQUIRES = [ | ||
| "urllib3 >= 2.7.0, < 3.0.0", | ||
| "python-dateutil >= 2.8.2", | ||
|
|
||
There was a problem hiding this comment.
Choose a reason for hiding this comment
The reason will be displayed to describe this comment to others. Learn more.
P2: Python 3.15 is still excluded from this workflow because the new matrix entry is commented out. Enable the entry so this pydantic-v1 echo sample actually validates the newly supported Python version.
Prompt for AI agents